This incident has been fully resolved. The earlier disruption was caused by a Cloudflare Global Network outage, which temporarily affected access to the Dojah Website, Dashboard, Identity Widget, and some API endpoints. Cloudflare has restored normal network operations, and all Dojah services are now stable and functioning as expected.
We have verified system performance and confirmed no further impact. Thank you for your patience while we worked through this incident.
Resolved
This incident has been fully resolved. The earlier disruption was caused by a Cloudflare Global Network outage, which temporarily affected access to the Dojah Website, Dashboard, Identity Widget, and some API endpoints. Cloudflare has restored normal network operations, and all Dojah services are now stable and functioning as expected.
We have verified system performance and confirmed no further impact. Thank you for your patience while we worked through this incident.
Monitoring
All Dojah services have recovered and are now operating normally following the earlier Cloudflare network disruption. We are continuing to closely monitor system performance to ensure stability across the Website, Dashboard, Identity Widget, and APIs.
At this time, no further customer impact is expected. We will transition this incident to “Resolved” once we confirm sustained stability.
Monitoring
Cloudflare has implemented a fix for the network issue impacting our services, and we are beginning to see recovery across the Dojah Website, Dashboard, Identity Widget, and API endpoints. Our team is actively monitoring service performance and stability to ensure full restoration.
Some users may still experience intermittent latency or brief connection failures as global network traffic normalizes. We will continue to observe systems closely and provide another update once all services are fully stable.
Identified
We have identified that the ongoing disruption affecting the Dojah Website, Dashboard, Identity Widget, and some API endpoints is caused by a major outage on the Cloudflare Global Network. This external issue is impacting connectivity and routing, resulting in full outages for some services and degraded performance on others.
Our infrastructure remains healthy, but Cloudflare’s network instability is preventing normal access to our systems. We are closely monitoring Cloudflare’s incident and will restore full functionality as soon as the upstream provider resolves their network issue.
We will continue to provide updates as more information becomes available.
Investigating
We are currently experiencing a major service disruption affecting multiple Dojah services. Initial investigation indicates the issue is due to an ongoing Cloudflare Global Network outage, which is impacting connectivity, API availability, and dashboard access for several customers.
Cloudflare has confirmed the incident on their status page and is actively investigating. As a result, users may experience intermittent failures, latency spikes, or complete inability to reach our services.
We are monitoring Cloudflare’s updates closely and continuing internal checks to ensure no additional failures are occurring within our infrastructure. Further updates will be provided as we learn more.